玩客云linux升级

原创 九站  2023-01-17 10:35:04  阅读 169 次 评论 0 条

image.png

apt update
apt list --upgradable
apt upgrade

aptitude、apt-get和 apt 命令

APT 是个原先有图形接口的大计划。以包括核心应用程序的程序库为基础,且第一个前端 apt-get — 基于命令行 — 也包括在项目开发中。apt 是 APT 的第二个基于命令行的前端,包括若干 apt-get 错误的处理。

安装和卸载

通过APT,软件包可以从系统中添加或移除,命令分别为 apt install 软件包 、 apt remove 软件包 。在以上两种情况中,APT 将会自动安装必要的依赖包或者删除依赖于删除包的软件包。 apt purge 软件包 命令包含一个彻底删除 — 相关的配置文件也会被删除。

系统升级

apt 会选择最新的版本号 (除了来自 Experimental 与 stable-backports,其缺省忽略版本号)。若在 sources.list 内指定 测试版 或 不稳定版 ,则 apt upgrade 会把 稳定版 系统切换至 测试版 或 不稳定版,这些可能不是您要的。

40 packages can be upgraded. Run 'apt list --upgradable' to see them.N: Repository 'http://deb.debian.org/debian bullseye InRelease' changed its 'Version' value from '11.5' to '11.6'root@onecloud:~# apt list --upgradableListing... Donearmbian-bsp-cli-onecloud/bullseye 22.11.1 armhf [upgradable from: 22.08.8]armbian-config/bullseye 22.11.2 all [upgradable from: 22.08.6]armbian-firmware/bullseye 22.11.2 all [upgradable from: 22.08.6]armbian-zsh/bullseye 22.11.2 all [upgradable from: 22.08.6]base-files/stable 11.1+deb11u6 armhf [upgradable from: 11.1+deb11u5]containerd.io/bullseye 1.6.15-1 armhf [upgradable from: 1.6.9-1]distro-info-data/stable 0.51+deb11u3 all [upgradable from: 0.51+deb11u2]docker-ce-cli/bullseye 5:20.10.22~3-0~debian-bullseye armhf [upgradable from: 5:20.10.21~3-0~debian-bullseye]docker-ce-rootless-extras/bullseye 5:20.10.22~3-0~debian-bullseye armhf [upgradable from: 5:20.10.21~3-0~debian-bullseye]docker-ce/bullseye 5:20.10.22~3-0~debian-bullseye armhf [upgradable from: 5:20.10.21~3-0~debian-bullseye]docker-compose-plugin/bullseye 2.14.1~debian-bullseye armhf [upgradable from: 2.12.2~debian-bullseye]libapache2-mod-php7.4/stable,stable-security 7.4.33-1+deb11u1 armhf [upgradable from: 7.4.30-1+deb11u1]libgssapi-krb5-2/stable,stable-security 1.18.3-6+deb11u3 armhf [upgradable from: 1.18.3-6+deb11u2]libk5crypto3/stable,stable-security 1.18.3-6+deb11u3 armhf [upgradable from: 1.18.3-6+deb11u2]libkrb5-3/stable,stable-security 1.18.3-6+deb11u3 armhf [upgradable from: 1.18.3-6+deb11u2]libkrb5support0/stable,stable-security 1.18.3-6+deb11u3 armhf [upgradable from: 1.18.3-6+deb11u2]libksba8/stable-security 1.5.0-3+deb11u2 armhf [upgradable from: 1.5.0-3+deb11u1]libnginx-mod-http-geoip/stable,stable-security 1.18.0-6.1+deb11u3 armhf [upgradable from: 1.18.0-6.1+deb11u2]libnginx-mod-http-image-filter/stable,stable-security 1.18.0-6.1+deb11u3 armhf [upgradable from: 1.18.0-6.1+deb11u2]libnginx-mod-http-xslt-filter/stable,stable-security 1.18.0-6.1+deb11u3 armhf [upgradable from: 1.18.0-6.1+deb11u2]libnginx-mod-mail/stable,stable-security 1.18.0-6.1+deb11u3 armhf [upgradable from: 1.18.0-6.1+deb11u2]libnginx-mod-stream-geoip/stable,stable-security 1.18.0-6.1+deb11u3 armhf [upgradable from: 1.18.0-6.1+deb11u2]libnginx-mod-stream/stable,stable-security 1.18.0-6.1+deb11u3 armhf [upgradable from: 1.18.0-6.1+deb11u2]libpixman-1-0/stable,stable-security 0.40.0-1.1~deb11u1 armhf [upgradable from: 0.40.0-1]libtasn1-6/stable 4.16.0-2+deb11u1 armhf [upgradable from: 4.16.0-2]linux-dtb-edge-meson/bullseye 22.11.1 armhf [upgradable from: 22.08.6]linux-image-edge-meson/bullseye 22.11.1 armhf [upgradable from: 22.08.6]linux-libc-dev/bullseye 22.11.1 armhf [upgradable from: 22.08.6]nala/scar 0.12.0 all [upgradable from: 0.11.0]nano/stable 5.4-2+deb11u2 armhf [upgradable from: 5.4-2+deb11u1]nginx-common/stable,stable-security 1.18.0-6.1+deb11u3 all [upgradable from: 1.18.0-6.1+deb11u2]nginx-core/stable,stable-security 1.18.0-6.1+deb11u3 armhf [upgradable from: 1.18.0-6.1+deb11u2]nginx/stable,stable-security 1.18.0-6.1+deb11u3 all [upgradable from: 1.18.0-6.1+deb11u2]php7.4-cli/stable,stable-security 7.4.33-1+deb11u1 armhf [upgradable from: 7.4.30-1+deb11u1]php7.4-common/stable,stable-security 7.4.33-1+deb11u1 armhf [upgradable from: 7.4.30-1+deb11u1]php7.4-fpm/stable,stable-security 7.4.33-1+deb11u1 armhf [upgradable from: 7.4.30-1+deb11u1]php7.4-json/stable,stable-security 7.4.33-1+deb11u1 armhf [upgradable from: 7.4.30-1+deb11u1]php7.4-opcache/stable,stable-security 7.4.33-1+deb11u1 armhf [upgradable from: 7.4.30-1+deb11u1]php7.4-readline/stable,stable-security 7.4.33-1+deb11u1 armhf [upgradable from: 7.4.30-1+deb11u1]php7.4/stable,stable-security 7.4.33-1+deb11u1 all [upgradable from: 7.4.30-1+deb11u1]
Reading package lists... DoneBuilding dependency tree... DoneReading state information... DoneCalculating upgrade... DoneThe following packages will be upgraded:
  armbian-bsp-cli-onecloud armbian-config armbian-firmware armbian-zsh base-files containerd.io distro-info-data docker-ce docker-ce-cli
  docker-ce-rootless-extras docker-compose-plugin libapache2-mod-php7.4 libgssapi-krb5-2 libk5crypto3 libkrb5-3 libkrb5support0 libksba8
  libnginx-mod-http-geoip libnginx-mod-http-image-filter libnginx-mod-http-xslt-filter libnginx-mod-mail libnginx-mod-stream libnginx-mod-stream-geoip
  libpixman-1-0 libtasn1-6 linux-dtb-edge-meson linux-image-edge-meson linux-libc-dev nala nano nginx nginx-common nginx-core php7.4 php7.4-cli
  php7.4-common php7.4-fpm php7.4-json php7.4-opcache php7.4-readline40 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.Need to get 130 MB of archives.After this operation, 602 kB of additional disk space will be used.Do you want to continue? [Y/n]
Configuration file '/usr/lib/armbian/armbian-apt-updates'
 ==> File on system created by you or by a script.          系统上由您或脚本创建的文件。
 ==> File also in package provided by package maintainer.   文件也在包维护者提供的包中。
   What would you like to do about it ?  Your options are:  你想怎么办? 您的选择是:
    Y or I  : install the package maintainer's version      Y 或 I :安装包维护者的版本
    N or O  : keep your currently-installed version         N 或 O :保留您当前安装的版本
      D     : show the differences between the versions     D : 显示版本之间的差异
      Z     : start a shell to examine the situation        Z :启动 shell 来检查情况
 The default action is to keep your current version.        默认操作是保留当前版本。
*** armbian-apt-updates (Y/I/N/O/D/Z) [default=N] ?


linux命令查询

本文地址:https://v6.lpv4.cn/?id=6
版权声明:本文为原创文章,版权归 九站 所有,欢迎分享本文,转载请保留出处!
未知IP

发表评论


表情

还没有留言,还不快点抢沙发?